SUSE Linux Enterprise

ØMQ core (libzmq)

2.2 series

The zeromq 2.2 series for SUSE Linux Enterprise (SLE) is available in openSUSE Build Service (OBS) project zeromq (2.2.0 released) and zeromq-2.x-latest (2.2.x latest).

To install 2.2.0 stable on SLES 11SP2:

zypper -p -v in zeromq

For development files:
zypper -p -v in zeromq-devel

The zypper of SLES 10 doesn't support direct install. The repository must be added to zypper first.

zypper sa

Then you can install zeromq or zeromq-devel
zypper in zeromq

zypper in zeromq-devel

There are also builds for SLES 11 and SLES 11SP1 from the OBS project page. Similar repositories are also configured in zeromq-2.x-latest (2.2.x latest) project.

3.2 series

The 3.2 series is available in OBS project zeromq-3.x-latest.

To install on SLES 11SP2:

zypper -p -v in zeromq

And development files
zypper -p -v in zeromq-devel

Make sure current 3.x series is not GA now. The above builds are based on the Git latest source. SLES 10 are not supported in 3.x Git latest build because of the autoconf requirement.


CZMQ 1.1.0 is supported on SUSE 10 by the same OBS project. After added the repository, simply using:

zypper in libczmq

zypper in libczmq-devel

CZMQ (1.1.0 or latest Git source) is not yet available on SLES 11 due to some compiling problems.

The SLES packaging is maintained by Feng Shuo. Please report bugs to openSUSE bugzilla in the OBS project pages.