8th Binding

Source Code

Included in the 8th distribution (http://8th-dev.com/)

Development environment

8th (on any desktop platform)

Build and installation

You will first need to install the ØMQ library (version 4.2 or later). If 8th is installed, you simply invoke the phrase "needs net/zmq" in order to use the 0MQ bindings in 8th.

Sample code

The 8th distribution contains the sample 'samples/net/zmqcli.8th', which is a port to 8th of the 'wuclient' sample from the zguide.

Bug Reporting

If you encounter problems please fill a bug report on the 8th forum at:


Discussions about this language binding take place on that forum as well.